summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:56:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:40 +0100
commit43a70edc291de476d705805230f61458de992f70 (patch)
treecf6181195d1520fa8bde3e3595ba2e178dfafd77
parent1442ca73402ba7904830204e59aa2d76bd85af46 (diff)
downloadguix-patches-43a70edc291de476d705805230f61458de992f70.tar
guix-patches-43a70edc291de476d705805230f61458de992f70.tar.gz
gnu: Add r-acet.
* gnu/packages/cran.scm (r-acet): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 91f842e8f4..8c7fe23667 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16996,3 +16996,29 @@ available in closed form and the design space can be continuous and of high
dimensionality. This package uses @dfn{Approximate Coordinate Exchange} (ACE)
to maximise an approximation to the expectation of the utility function.")
(license license:gpl2)))
+
+(define-public r-acet
+ (package
+ (name "r-acet")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ACEt" version))
+ (sha256
+ (base32
+ "0626d6kg485xjya164wagrr5z223jvi93ywbwpdns7fkm03c0dlq"))))
+ (properties `((upstream-name . "ACEt")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bh" ,r-bh)
+ ("r-mass" ,r-mass)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (home-page "https://cran.r-project.org/web/packages/ACEt/")
+ (synopsis "Estimating dynamic heritability and twin model comparison")
+ (description
+ "This package supports twin models that are able to estimate the dynamic
+behaviour of the variance components in the classical twin models with respect
+to age using B-splines and P-splines.")
+ (license license:gpl2+)))