summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 23:09:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:54 +0100
commit270529f633e3636bc10cc00ae5081093bb2e95cb (patch)
treec75cbc1a9567034969742b438b52c8ce9ce8c681
parentf18c0544f6dd48aee582d95a0d6400939fa8b441 (diff)
downloadguix-patches-270529f633e3636bc10cc00ae5081093bb2e95cb.tar
guix-patches-270529f633e3636bc10cc00ae5081093bb2e95cb.tar.gz
gnu: Add r-genalg.
* gnu/packages/cran.scm (r-genalg): New variable.
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d7b8e866d6..9edf9eaf7f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17500,3 +17500,23 @@ moderate-sized data sets. It performs discrete, real, and gentle boost under
both exponential and logistic loss on a given data set.")
;; Any version of the GPL.
(license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-genalg
+ (package
+ (name "r-genalg")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "genalg" version))
+ (sha256
+ (base32
+ "1wzfamq8k5yhwbdx0wy1w5bks93brj0p890xxc4yqrja4w38ja3s"))))
+ (properties `((upstream-name . "genalg")))
+ (build-system r-build-system)
+ (home-page "https://github.com/egonw/genalg")
+ (synopsis "R based genetic algorithm")
+ (description
+ "This package provides an R based genetic algorithm for binary and
+floating point chromosomes.")
+ (license license:gpl2)))