summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 10:56:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:56 +0100
commit1830e0383b808a1a1b943f714335cf36efc38795 (patch)
tree05abd29e7f5a9584626345ad1417234e849472d4
parent5f08fa64f023192c1aef0b34afb00b17bdd591de (diff)
downloadguix-patches-1830e0383b808a1a1b943f714335cf36efc38795.tar
guix-patches-1830e0383b808a1a1b943f714335cf36efc38795.tar.gz
gnu: Add r-expint.
* gnu/packages/cran.scm (r-expint): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ba322ee220..7bb4726fd1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18132,3 +18132,26 @@ plot the data. The central type of plot is the actogram, as first described
in \"Activity and distribution of certain wild mice in relation to biotic
communities\" by MS Johnson (1926) @url{doi:10.2307/1373575}.")
(license license:gpl3)))
+
+(define-public r-expint
+ (package
+ (name "r-expint")
+ (version "0.1-6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "expint" version))
+ (sha256
+ (base32
+ "0iai25cglcdnf44d2d1fz1xpw4q600my4zq4493fk4cs5673mlf7"))))
+ (properties `((upstream-name . "expint")))
+ (build-system r-build-system)
+ (home-page "https://gitlab.com/vigou3/expint")
+ (synopsis "Exponential integral and incomplete Gamma function")
+ (description
+ "This package provides the exponential integrals @code{E_1(x)},
+@code{E_2(x)}, @code{E_n(x)} and @code{Ei(x)}, and the incomplete gamma
+function @code{G(a, x)} defined for negative values of its first argument.
+The package also gives easy access to the underlying C routines through an
+API; see the package vignette for details.")
+ (license license:gpl2+)))