summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:41:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:38 +0100
commit0379a167612f40e525251f4c1b92c9150405af7d (patch)
tree8009270ba25af0d993c579d3791b05c4d57b6d1d
parent72b67e0b36cd472c893f99f4a3ab9a491e41000b (diff)
downloadguix-patches-0379a167612f40e525251f4c1b92c9150405af7d.tar
guix-patches-0379a167612f40e525251f4c1b92c9150405af7d.tar.gz
gnu: Add r-accept.
* gnu/packages/cran.scm (r-accept): New variable.
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f931aa67e3..385b97adfc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16601,3 +16601,32 @@ included.")
elicitation options based on Kass and Vaidyanathan (1992)
@url{doi:10.1111/j.2517-6161.1992.tb01868.x}.")
(license license:gpl2+)))
+
+(define-public r-accept
+ (package
+ (name "r-accept")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "accept" version))
+ (sha256
+ (base32
+ "1r4mhy9g4wjcjgdd0gwdarmr09292il3vdkmx0hz7vh9mffyr9kx"))))
+ (properties `((upstream-name . "accept")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-extrafont" ,r-extrafont)
+ ("r-mass" ,r-mass)
+ ("r-plotly" ,r-plotly)
+ ("r-stringr" ,r-stringr)
+ ("r-viridis" ,r-viridis)))
+ (home-page "https://cran.r-project.org/web/packages/accept/")
+ (synopsis "Acute COPD Exacerbation Prediction Tool (ACCEPT)")
+ (description
+ "This package allows clinicians to predict the rate and severity of
+future acute exacerbation in @dfn{Chronic Obstructive Pulmonary
+Disease} (COPD) patients, based on the clinical prediction model published in
+Adibi et al. (2019) @url{doi:10.1101/651901}.")
+ (license license:gpl3)))