summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2022-02-05 11:21:00 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-06 23:03:50 +0100
commitf424c3123d2ed174b889a7fa6e8bc6ac3a279661 (patch)
tree00e189f8b0283e4d1ce82cb086d4b7a7ad0e10d4
parentb55241fa678ba90eb002c7fa14da13ae6a7004eb (diff)
downloadguix-patches-f424c3123d2ed174b889a7fa6e8bc6ac3a279661.tar
guix-patches-f424c3123d2ed174b889a7fa6e8bc6ac3a279661.tar.gz
gnu: emacs-bash-completion: Update to 3.1.0-0.c5eaeed.
* gnu/packages/emacs-xyz.scm (emacs-bash-completion): Update to 3.1.0-0.c5eaeed. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm72
1 files changed, 38 insertions, 34 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a994a438dd..884ebf3ec7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15937,41 +15937,45 @@ messaging service.")
Slack client.")
(license license:gpl3+))))
-
(define-public emacs-bash-completion
- (package
- (name "emacs-bash-completion")
- (version "3.1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/szermatt/emacs-bash-completion")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "11j2k3irixp47r2iglxdmjphahqhgnxg98n2xwagwzyq99lsamj4"))))
- (inputs (list bash))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-git-checkout-writable
- (λ _
- (for-each make-file-writable (find-files "."))
- #t))
- (add-before 'install 'configure
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((bash (assoc-ref inputs "bash")))
- (emacs-substitute-variables "bash-completion.el"
- ("bash-completion-prog" (string-append bash "/bin/bash"))))
- #t)))))
- (home-page "https://github.com/szermatt/emacs-bash-completion")
- (synopsis "Bash completion for the shell buffer")
- (description
- "@code{bash-completion} defines dynamic completion hooks for shell-mode
-and shell-command prompts that are based on Bash completion.")
- (license license:gpl2+)))
+ ;; Need to use a newer commit than the latest version in order to support
+ ;; completion interfaces that alters the candidate list provided by the
+ ;; package
+ (let ((commit "c5eaeed156ab906190c662d491269230967104b1")
+ (revision "0"))
+ (package
+ (name "emacs-bash-completion")
+ (version (git-version "3.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/szermatt/emacs-bash-completion")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r221iirqsbz13s76r68i496izbirrvcw8ql3wsh205zmxa3jqg1"))))
+ (inputs (list bash))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (λ _
+ (for-each make-file-writable (find-files "."))
+ #t))
+ (add-before 'install 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ (emacs-substitute-variables "bash-completion.el"
+ ("bash-completion-prog" (string-append bash "/bin/bash"))))
+ #t)))))
+ (home-page "https://github.com/szermatt/emacs-bash-completion")
+ (synopsis "Bash completion for the shell buffer")
+ (description
+ "@code{bash-completion} defines dynamic completion hooks for shell-mode
+ and shell-command prompts that are based on Bash completion.")
+ (license license:gpl2+))))
(define-public emacs-easy-kill
(package