summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2022-02-01 18:49:29 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-06 22:02:38 +0100
commit45fa5fec49315684197e6488951cc6bdc954e041 (patch)
tree391dd6a8d3023d4ade9fb2175ef3fae786070daf
parent3a0aa66b4ae3843b2713d714b6d9d68683b85be0 (diff)
downloadguix-patches-45fa5fec49315684197e6488951cc6bdc954e041.tar
guix-patches-45fa5fec49315684197e6488951cc6bdc954e041.tar.gz
gnu: Add emacs-tempel.
* gnu/packages/emacs-xyz.scm (emacs-tempel): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0dbe580fc7..a8fbcc5dbd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12913,6 +12913,27 @@ been adapted to work with mu4e.")
"Emacs minor mode for redisplaying parts of the buffer as pretty symbols.")
(license license:gpl3+)))
+(define-public emacs-tempel
+ (package
+ (name "emacs-tempel")
+ (version "0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minad/tempel")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16972j2qq03q65qszgjjkzl52f79hk007kyi249wg1bqhvfa59b6"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/minad/tempel")
+ (synopsis "Simple templates for Emacs")
+ (description
+ "Tempel is a tiny template package for Emacs, which uses the syntax of
+the Emacs Tempo library. You may also write your templates in Lisp.")
+ (license license:gpl3+)))
+
(define-public emacs-yasnippet
(package
(name "emacs-yasnippet")