summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Dvorsak <eric@dvorsak.fr>2015-08-17 22:06:01 +0200
committerEric Bavier <bavier@member.fsf.org>2015-08-23 11:26:03 -0500
commitd8f1c07499d31dbb2e809a43e2448df0158ad875 (patch)
tree75431aa9198133dd59875206d6dcb6f7c4e489dc
parentf187b2a29faa125cca36ca2b95ed26cae93d4207 (diff)
downloadguix-patches-d8f1c07499d31dbb2e809a43e2448df0158ad875.tar
guix-patches-d8f1c07499d31dbb2e809a43e2448df0158ad875.tar.gz
gnu: Add libyajl.
* gnu/packages/web.scm (libyajl): New variable. Signed-off-by: Eric Bavier <bavier@member.fsf.org>
-rw-r--r--gnu/packages/web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 48bfbc7747..0a68d23da0 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -287,6 +288,26 @@ parse JSON formatted strings back into the C representation of JSON objects.")
style API.")
(license l:expat)))
+(define-public libyajl
+ (package
+ (name "libyajl")
+ (version "2.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lloyd/yajl/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0nmcqpaiq4pv7dymyg3n3jsd57yhp5npxl26a1hzw3m3lmj37drz"))))
+ (build-system cmake-build-system)
+ (home-page "https://lloyd.github.io/yajl/")
+ (synopsis "C library for parsing JSON")
+ (description
+ "Yet Another JSON Library (YAJL) is a small event-driven (SAX-style) JSON
+parser written in ANSI C and a small validating JSON generator.")
+ (license l:isc)))
+
(define-public libwebsockets
(package
(name "libwebsockets")