summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:09:53 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:54 -0400
commitf8270331020ed4051a4ef51151a2622bb95ef3b7 (patch)
treeb78cc5117d3b34e54f27069b9a2eb81311dcb56c
parenta71f861752f5e060757ced0ae077e7fab9f9e27d (diff)
downloadguix-patches-f8270331020ed4051a4ef51151a2622bb95ef3b7.tar
guix-patches-f8270331020ed4051a4ef51151a2622bb95ef3b7.tar.gz
gnu: Add ghc-tar.
* gnu/packages/haskell.scm (ghc-tar): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cbb1ba7f72..861f59456e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6719,4 +6719,36 @@ test-framework.")
(description "ByteString-backed Handles") ; There is no description
(license license:bsd-3)))
+(define-public ghc-tar
+ (package
+ (name "ghc-tar")
+ (version "0.5.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/tar/tar-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "18qq94j9bm91iswnxq2dm5dws5c7wm4k01q2rpf8py35cf3svnfq"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-bytestring-handle" ,ghc-bytestring-handle)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-array" ,ghc-array)))
+ (home-page "http://hackage.haskell.org/package/tar")
+ (synopsis "Reading, writing and manipulating \".tar\" archive files")
+ (description
+ "This library is for working with \\\"@.tar@\\\" archive files.
+It can read and write a range of common variations of the tar archive format
+including V7, POSIX USTAR and GNU formats. It provides support for packing and
+unpacking portable archives. This makes it suitable for distribution but not
+backup because details like file ownership and exact permissions are not
+preserved. It also provides features for random access to archive content using
+an index.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here