summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:04 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:57 -0400
commitd4cca6b0ae238b24839cac1bf2c361046996ad54 (patch)
treedc234ffb47e68f852891cbd62c7c17812e6cd8fb
parentce242fd05eda0f0ffddb05f895358be0648881e7 (diff)
downloadguix-patches-d4cca6b0ae238b24839cac1bf2c361046996ad54.tar
guix-patches-d4cca6b0ae238b24839cac1bf2c361046996ad54.tar.gz
gnu: Add ghc-fgl-arbitrary.
* gnu/packages/haskell.scm (ghc-fgl-arbitrary): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ae343a24d4..f3efe199d4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6975,4 +6975,31 @@ files and directories in a portable way.")
"A clone of wl-pprint for use with the text library.")
(license license:bsd-3)))
+(define-public ghc-fgl-arbitrary
+ (package
+ (name "ghc-fgl-arbitrary")
+ (version "0.2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/fgl-arbitrary/fgl-arbitrary-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12qbsla4vivffris6y3gj29vrafkpyazqdbdy2m55nggypqpf7ah"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-fgl" ,ghc-fgl)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)))
+ (home-page "http://hackage.haskell.org/package/fgl-arbitrary")
+ (synopsis "QuickCheck support for fgl")
+ (description
+ "Provides Arbitrary instances for fgl graphs to avoid adding a
+QuickCheck dependency for fgl whilst still making the instances
+available to others. Also available are non-fgl-specific functions
+for generating graph-like data structures.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here