summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-10 18:12:53 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-10 21:15:43 +0100
commitc3188c9accaa0299ea181617b5ab6a5682837e58 (patch)
tree89f40e35f03d1a7aed0c81bebe06ea9901eb8e17
parent2bdf9cb38c82a460632c9866f80278da1b35b12d (diff)
downloadguix-patches-c3188c9accaa0299ea181617b5ab6a5682837e58.tar
guix-patches-c3188c9accaa0299ea181617b5ab6a5682837e58.tar.gz
gnu: nghttp2: Remove GCC7 workaround.
* gnu/packages/web.scm (nghttp2)[native-inputs]: Remove GCC-7. [arguments]: Remove phase 'work-around-bug-30756'.
-rw-r--r--gnu/packages/web.scm4
1 files changed, 0 insertions, 4 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 158d542d7f..129e8861a8 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6255,7 +6255,6 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
"lib")) ; only libnghttp2
(native-inputs
`(("pkg-config" ,pkg-config)
- ("gcc" ,gcc-7) ; 1.35.0 requires GCC6 or later
;; Required by tests.
("cunit" ,cunit)
@@ -6287,9 +6286,6 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
(("@prefix@")
(assoc-ref outputs "lib")))
#t))
- (add-before 'configure 'work-around-bug-30756
- (lambda _
- (for-each unsetenv '("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH")) #t))
(add-before 'check 'set-timezone-directory
(lambda* (#:key inputs #:allow-other-keys)
(setenv "TZDIR" (string-append (assoc-ref inputs "tzdata")