summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:09:52 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:54 -0400
commita71f861752f5e060757ced0ae077e7fab9f9e27d (patch)
tree66030c2a17f165a3d383e8328b9f0b8427383df9
parente9e519be76b26e6ac6f55fa335f547602b5578fa (diff)
downloadguix-patches-a71f861752f5e060757ced0ae077e7fab9f9e27d.tar
guix-patches-a71f861752f5e060757ced0ae077e7fab9f9e27d.tar.gz
gnu: Add ghc-bytestring-handle.
* gnu/packages/haskell.scm (ghc-bytestring-handle): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3213a2edb3..cbb1ba7f72 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6694,4 +6694,29 @@ test-framework.")
(description "Reasonably fast data encoding library.")
(license license:bsd-3)))
+(define-public ghc-bytestring-handle
+ (package
+ (name "ghc-bytestring-handle")
+ (version "0.1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/bytestring-handle/bytestring-handle-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0q5yzx90ad9w7qvaix05bynxwlsbqjrgfc4hqb355ibf991wd0rh"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)))
+ (home-page "http://hub.darcs.net/ganesh/bytestring-handle")
+ (synopsis "ByteString-backed Handles")
+ (description "ByteString-backed Handles") ; There is no description
+ (license license:bsd-3)))
+
;;; haskell.scm ends here