summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-22 12:19:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-02-05 19:44:28 +0200
commita1e84575a4bea5bbc9c742a32f2caebc48e0c587 (patch)
tree054031c455bfdc3e8169cd6a7fb5831d1e428780
parentf57883ec79815a0b502e3dee462d0d27a7018e79 (diff)
downloadguix-patches-a1e84575a4bea5bbc9c742a32f2caebc48e0c587.tar
guix-patches-a1e84575a4bea5bbc9c742a32f2caebc48e0c587.tar.gz
gnu: libfaketime: Adjust flags on riscv64-linux.
* gnu/packages/check.scm (libfaketime)[arguments]: When building for riscv64-linux adjust CFLAGS to make the package work.
-rw-r--r--gnu/packages/check.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4115a5c22b..913c803a24 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2808,7 +2808,8 @@ portable to just about any platform.")
;; indefinitely. See README.packagers for more information.
;; There are specific instructions to not enable more flags
;; than absolutely needed.
- ,(if (target-ppc64le?)
+ ,(if (or (target-ppc64le?)
+ (target-riscv64?))
`(setenv "FAKETIME_COMPILE_CFLAGS"
"-DFORCE_MONOTONIC_FIX -DFORCE_PTHREAD_NONVER")
`(setenv "FAKETIME_COMPILE_CFLAGS"