summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-31 15:25:22 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-31 15:25:22 +0200
commit9055b93513f93293890154790928bb9675770cfe (patch)
tree6bcd88ab2ec56e9ee4b72ca8577388a1065cca25
parente227b0820a93c4a264a169895948d6d2c0c37005 (diff)
downloadguix-patches-9055b93513f93293890154790928bb9675770cfe.tar
guix-patches-9055b93513f93293890154790928bb9675770cfe.tar.gz
gnu: f2fs-tools: Fix building with gcc-10.
* gnu/packages/linux.scm (f2fs-tools-1.7)[arguments]: Pass '-fcommon' to CFLAGS.
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1f52bccee8..63f0e4108c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2021 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5497,7 +5498,8 @@ obviously it can be shared with files outside our set).")
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags '("CFLAGS=-fcommon")
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'install-headers
(lambda* (#:key outputs #:allow-other-keys)