summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 23:10:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 23:17:35 +0100
commit7145f4e519d47ad0a02f320be38d135d96e74792 (patch)
treead5a8866a7861218632f51ec5a1adc4dc79c77fa
parente0a8fc85dd1ee9e9ceef790b311691068a664a28 (diff)
downloadguix-patches-7145f4e519d47ad0a02f320be38d135d96e74792.tar
guix-patches-7145f4e519d47ad0a02f320be38d135d96e74792.tar.gz
gnu: ritornello: Fetch sources from git.
* gnu/packages/bioinformatics.scm (ritornello)[source]: Fetch from git.
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3d230a1036..fa455c5125 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11258,14 +11258,14 @@ sort, markdup, and depth.")
(name "ritornello")
(version "1.0.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/KlugerLab/"
- "Ritornello/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KlugerLab/Ritornello.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "02nik86gq9ljjriv6pamwlmqnfky3ads1fpklx6mc3hx6k40pg38"))))
+ "1xpki1pkxwmn7n5n23vv64zvikss4fj53vlzhnp3j34wrmxik3h8"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; there are no tests