summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-20 21:17:41 -0400
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:58 -0400
commit6aab9ba6d445d3eac32582caa045ebe88374e5aa (patch)
treef202287febf450a40ef8cf94056450b0399fd25e
parente7e2f03c8f3cb8d5e376af6b67704849246aafa6 (diff)
downloadguix-patches-6aab9ba6d445d3eac32582caa045ebe88374e5aa.tar
guix-patches-6aab9ba6d445d3eac32582caa045ebe88374e5aa.tar.gz
gnu: Add ghc-constraints.
* gnu/packages/haskell.scm (ghc-constraints): New variable.
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1586923134..91e87789dd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7067,4 +7067,30 @@ the classes @code{IArray} of immutable arrays and @code{MArray} of arrays mutabl
within appropriate monads, as well as some instances of these classes.")
(license license:bsd-3)))
+(define-public ghc-constraints
+ (package
+ (name "ghc-constraints")
+ (version "0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/constraints/constraints-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "120mmv9rwbahslisc1z8zx9lw7v6hl5fzid4l0hiy5as6ijqgl2c"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-hashable" ,ghc-hashable)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)))
+ (home-page "http://github.com/ekmett/constraints/")
+ (synopsis "Constraint manipulation")
+ (description
+ "GHC 7.4 gave us the ability to talk about @code{ConstraintKinds}.
+They stopped crashing the compiler in GHC 7.6. This package provides
+a vocabulary for working with them.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here