summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-03 21:14:14 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-03 21:16:43 -0500
commit4b562d46a530048ccc0c1d6bf33bd667a92c6780 (patch)
tree09140182f0ee2e978f40bb8feea8892505fd16bf
parent4b47c608284bb57a55aa6d1a0b97743405cbad87 (diff)
downloadguix-patches-4b562d46a530048ccc0c1d6bf33bd667a92c6780.tar
guix-patches-4b562d46a530048ccc0c1d6bf33bd667a92c6780.tar.gz
gnu: python-flake8-polyfill: Please the sanity-check phase.
* gnu/packages/python-xyz.scm (python-flake8-polyfill) [native-inputs]{python-flake8}: Move to... [propagated-inputs]: ... here.
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 592e204765..7768891c6a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8476,9 +8476,10 @@ unnecessary plus operators for explicit string literal concatenation.")
(("\\[pytest\\]")
"[tool:pytest]"))
(invoke "py.test" "-v"))))))
+ (propagated-inputs
+ `(("python-flake8" ,python-flake8)))
(native-inputs
- `(("python-flake8" ,python-flake8)
- ("python-mock" ,python-mock)
+ `(("python-mock" ,python-mock)
("python-pep8" ,python-pep8)
("python-pycodestyle" ,python-pycodestyle)
("python-pytest" ,python-pytest)))