summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:11 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:58 -0400
commit3f7aa1029b10e420f9b28829ce8badf8f6d19bc1 (patch)
tree904a014a30afa97d6cdf0c972464f6a17a3c5b76
parentddd5955b1ed0b4a3d67d91d027ee88165bf865e3 (diff)
downloadguix-patches-3f7aa1029b10e420f9b28829ce8badf8f6d19bc1.tar
guix-patches-3f7aa1029b10e420f9b28829ce8badf8f6d19bc1.tar.gz
gnu: Add ghc-system-fileio-bootstrap.
* gnu/packages/haskell.scm (ghc-system-fileio-bootstrap): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 00f5872b8d..52498e3568 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7156,4 +7156,36 @@ Unlike the filepath package, this package does not simply reuse String,
increasing type safety.")
(license license:expat)))
+;; See ghc-system-filepath-bootstrap. In addition this package depends on
+;; ghc-system-filepath.
+(define ghc-system-fileio-bootstrap
+ (package
+ (name "ghc-system-fileio-bootstrap")
+ (version "0.3.16.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/system-fileio/system-fileio-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1484hcl27s2qcby8ws5djj11q9bz68bspcifz9h5gii2ndy70x9i"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:tests? #f))
+ (inputs
+ `(("ghc-system-filepath-bootstrap" ,ghc-system-filepath-bootstrap)
+ ("ghc-text" ,ghc-text)
+ ("ghc-temporary" ,ghc-temporary)))
+ (home-page "https://github.com/fpco/haskell-filesystem")
+ (synopsis "Consistent filesystem interaction across GHC versions")
+ (description
+ "This is a small wrapper around the directory, unix, and Win32 packages,
+for use with system-filepath. It provides a consistent API to the various
+versions of these packages distributed with different versions of GHC.
+In particular, this library supports working with POSIX files that have paths
+which can't be decoded in the current locale encoding.")
+ (license license:expat)))
+
;;; haskell.scm ends here