summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-08 09:15:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-08 09:15:05 +0100
commit3da3cedf76b4f19af5db5a6122a6d98f6fa7fa67 (patch)
tree151d14981c28a32e6c94d608c1b977b6bbe68ef2
parente78e54d029869f82fd13958b959ed549f73b7aa9 (diff)
downloadguix-patches-3da3cedf76b4f19af5db5a6122a6d98f6fa7fa67.tar
guix-patches-3da3cedf76b4f19af5db5a6122a6d98f6fa7fa67.tar.gz
gnu: ngs-sdk: Use INVOKE.
* gnu/packages/bioinformatics.scm (ngs-sdk)[arguments]: Use INVOKE and return #T unconditionally.
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index eef42bc0f9..c501736c4b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5262,9 +5262,10 @@ Roche 454, Ion Torrent and Pacific BioSciences SMRT.")
;; The 'configure' script doesn't recognize things like
;; '--enable-fast-install'.
- (zero? (system* "./configure"
- (string-append "--build-prefix=" (getcwd) "/build")
- (string-append "--prefix=" out))))))
+ (invoke "./configure"
+ (string-append "--build-prefix=" (getcwd) "/build")
+ (string-append "--prefix=" out))
+ #t)))
(add-after 'unpack 'enter-dir
(lambda _ (chdir "ngs-sdk") #t)))))
(native-inputs `(("perl" ,perl)))