summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-04 20:06:58 +0100
committerMarius Bakke <marius@gnu.org>2022-02-05 00:27:46 +0100
commit2d5c270ec4f39b81ad07c6a4fc847c9e5997b822 (patch)
tree4d0af8bccc84f9c37bdc674188032dc6be7e1467
parentf0e638a57695134d79abc74d6c6e360cbd20e470 (diff)
downloadguix-patches-2d5c270ec4f39b81ad07c6a4fc847c9e5997b822.tar
guix-patches-2d5c270ec4f39b81ad07c6a4fc847c9e5997b822.tar.gz
gnu: python-pybtex: Fix test failure.
* gnu/packages/python-xyz.scm (python-pybtex)[arguments]: Run nosetests directly instead of via setup.py.
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 46419e8ace..7c1b5e8ed3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21816,7 +21816,12 @@ working with iterables.")
(inputs
(list python-latexcodec python-pyyaml python-six))
(arguments
- `(#:test-target "nosetests"))
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "nosetests")))))))
(home-page "https://pybtex.org/")
(synopsis "BibTeX-compatible bibliography processor")
(description "Pybtex is a BibTeX-compatible bibliography processor written