summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:09 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:58 -0400
commit2b41f4afc113bf7ea8d5151e5e389ae36d2c720b (patch)
tree999f8c181897056dc7ef44acf602fcdd69fa00ea
parent6aab9ba6d445d3eac32582caa045ebe88374e5aa (diff)
downloadguix-patches-2b41f4afc113bf7ea8d5151e5e389ae36d2c720b.tar
guix-patches-2b41f4afc113bf7ea8d5151e5e389ae36d2c720b.tar.gz
gnu: Add ghc-lifted-async.
* gnu/packages/haskell.scm (ghc-lifted-async): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 91e87789dd..92f3ccf413 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7093,4 +7093,36 @@ They stopped crashing the compiler in GHC 7.6. This package provides
a vocabulary for working with them.")
(license license:bsd-3)))
+(define-public ghc-lifted-async
+ (package
+ (name "ghc-lifted-async")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/lifted-async/lifted-async-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00fnwfcnc6niq9jbbb9rap9rkdgv5qhcglwanzc5fi8834j94c1r"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-async" ,ghc-async)
+ ("ghc-lifted-base" ,ghc-lifted-base)
+ ("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-constraints" ,ghc-constraints)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-th" ,ghc-tasty-th)))
+ (home-page "https://github.com/maoe/lifted-async")
+ (synopsis "Run lifted IO operations asynchronously and wait for their results")
+ (description
+ "This package provides IO operations from @code{async} package lifted to any
+instance of @code{MonadBase} or @code{MonadBaseControl}.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here