summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:12 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:59 -0400
commit25b3bdb5ffed180f1c7e393f3287d1e5d0364be7 (patch)
treeeae7290269c58a5457768a260b02327b5a65a5ba
parent3f7aa1029b10e420f9b28829ce8badf8f6d19bc1 (diff)
downloadguix-patches-25b3bdb5ffed180f1c7e393f3287d1e5d0364be7.tar
guix-patches-25b3bdb5ffed180f1c7e393f3287d1e5d0364be7.tar.gz
gnu: Add ghc-shelly.
* gnu/packages/haskell.scm (ghc-shelly): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 52498e3568..100efd65aa 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7188,4 +7188,40 @@ In particular, this library supports working with POSIX files that have paths
which can't be decoded in the current locale encoding.")
(license license:expat)))
+(define-public ghc-shelly
+ (package
+ (name "ghc-shelly")
+ (version "1.6.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/shelly/shelly-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0bg1pj5bhswfgwfgz66xr82i8cmjgrnx5ljvjy37052zxb82imnk"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("ghc-unix-compat" ,ghc-unix-compat)
+ ("ghc-system-filepath-bootstrap" ,ghc-system-filepath-bootstrap)
+ ("ghc-system-fileio-bootstrap" ,ghc-system-fileio-bootstrap)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-lifted-base" ,ghc-lifted-base)
+ ("ghc-lifted-async" ,ghc-lifted-async)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-enclosed-exceptions" ,ghc-enclosed-exceptions)
+ ("ghc-text" ,ghc-text)
+ ("ghc-async" ,ghc-async)
+ ("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-hspec" ,ghc-hspec)))
+ (home-page "https://github.com/yesodweb/Shelly.hs")
+ (synopsis "Shell-like (systems) programming in Haskell")
+ (description
+ "Shelly provides convenient systems programming in Haskell, similar in
+spirit to POSIX shells. Shelly is originally forked from the Shellish package.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here