summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:19 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:10:00 -0400
commit10a03d6665309903d614b87ab2d17278425feb2a (patch)
tree25d139713c6c4b19ab0e2ee7e761c9eadb5a6b2b
parent23feb6e4fbc42e47d0d36b8f7710366e5cf1e472 (diff)
downloadguix-patches-10a03d6665309903d614b87ab2d17278425feb2a.tar
guix-patches-10a03d6665309903d614b87ab2d17278425feb2a.tar.gz
gnu: Add ghc-system-fileio.
* gnu/packages/haskell.scm (ghc-system-fileio): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 35fcf6d847..9825dba5e1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7380,4 +7380,32 @@ Unlike the filepath package, this package does not simply reuse String,
increasing type safety.")
(license license:expat)))
+(define-public ghc-system-fileio
+ (package
+ (name "ghc-system-fileio")
+ (version "0.3.16.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/system-fileio/system-fileio-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1484hcl27s2qcby8ws5djj11q9bz68bspcifz9h5gii2ndy70x9i"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-system-filepath" ,ghc-system-filepath)
+ ("ghc-text" ,ghc-text)
+ ("ghc-chell" ,ghc-chell)
+ ("ghc-temporary" ,ghc-temporary)))
+ (home-page "https://github.com/fpco/haskell-filesystem")
+ (synopsis "Consistent filesystem interaction across GHC versions")
+ (description
+ "This is a small wrapper around the directory, unix, and Win32 packages,
+for use with system-filepath. It provides a consistent API to the various
+versions of these packages distributed with different versions of GHC.
+In particular, this library supports working with POSIX files that have paths
+which can't be decoded in the current locale encoding.")
+ (license license:expat)))
;;; haskell.scm ends here