summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-03 17:45:58 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-03 17:45:58 -0500
commit05e7bdf7ec1f93efe6cb8a977d7ca08951fc7f6f (patch)
tree909cff5dff6d030f0b02bbe23a670cac9864fac7
parent157b3020114c985068d8da49c30306d169e556d2 (diff)
downloadguix-patches-05e7bdf7ec1f93efe6cb8a977d7ca08951fc7f6f.tar
guix-patches-05e7bdf7ec1f93efe6cb8a977d7ca08951fc7f6f.tar.gz
gnu: python-astroid: Update to 2.4.2-1.5f67396.
* gnu/packages/python-xyz.scm (python-astroid): Update to 2.4.2-1.5f67396.
-rw-r--r--gnu/packages/python-xyz.scm59
1 files changed, 29 insertions, 30 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 219624c848..592e204765 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15370,35 +15370,34 @@ clone, while other processes access the original tree.")
(license license:gpl3+)))
(define-public python-astroid
- (package
- (name "python-astroid")
- (version "2.4.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "astroid" version))
- (sha256
- (base32 "00xp5gqxidxvgg1bwd91myqzdf2fpb9cjwbdl3p7gwqvlk17hh1g"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Check to see if the version pinning has been removed.
- (substitute* "astroid/__pkginfo__.py"
- (("==1\\.4\\.\\*") ">=1.4.0"))
- #t))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-lazy-object-proxy" ,python-lazy-object-proxy)
- ("python-six" ,python-six)
- ("python-wrapt" ,python-wrapt)))
- (native-inputs
- `(("python-dateutil" ,python-dateutil)
- ("python-pytest" ,python-pytest)
- ("python-pytest-runner" ,python-pytest-runner)))
- (home-page "https://github.com/PyCQA/astroid")
- (synopsis "Common base representation of python source code for pylint and
+ (let ((revision "1")
+ (commit "5f67396894c79c4661e357ec8bb03aa134a51109"))
+ (package
+ (name "python-astroid")
+ (version (git-version "2.4.2" revision commit))
+ (source
+ (origin
+ ;; The current 2.4.2 release doesn't support Python 3.9.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PyCQA/astroid")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ir5716wqgz39jva7x9chhjy41yi3n7fkymb8snh5giwig8kyipk"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-lazy-object-proxy" ,python-lazy-object-proxy)
+ ("python-six" ,python-six)
+ ("python-wrapt" ,python-wrapt)))
+ (native-inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/PyCQA/astroid")
+ (synopsis "Common base representation of python source code for pylint and
other projects")
- (description "@code{python-astroid} provides a common base representation
+ (description "@code{python-astroid} provides a common base representation
of python source code for projects such as pychecker, pyreverse, pylint, etc.
It provides a compatible representation which comes from the _ast module. It
@@ -15407,8 +15406,8 @@ down the AST and building an extended ast. The new node classes have
additional methods and attributes for different usages. They include some
support for static inference and local name scopes. Furthermore, astroid
builds partial trees by inspecting living objects.")
- (license license:lgpl2.1+)
- (properties `((python2-variant . ,(delay python2-astroid))))))
+ (license license:lgpl2.1+)
+ (properties `((python2-variant . ,(delay python2-astroid)))))))
(define-public python2-astroid
(let ((base (package-with-python2