summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:09:55 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:54 -0400
commit027b79762a31cb0b78d44a65ed9bc4343ad0954b (patch)
treede5e3b8c9c4d6cd7d040f8e74c11ac6a8964a1e3
parent54c37341d1720c5cdd3772e729a419f2f46b6fb2 (diff)
downloadguix-patches-027b79762a31cb0b78d44a65ed9bc4343ad0954b.tar
guix-patches-027b79762a31cb0b78d44a65ed9bc4343ad0954b.tar.gz
gnu: Add ghc-findbin.
* gnu/packages/haskell.scm (ghc-findbin): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9205e958c0..099c3e6c5b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6780,4 +6780,27 @@ which automatically lift operations introduced by monad transformers through
other transformers.")
(license license:bsd-3)))
+(define-public ghc-findbin
+ (package
+ (name "ghc-findbin")
+ (version "0.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/FindBin/FindBin-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "197xvn05yysmibm1p5wzxfa256lvpbknr5d1l2ws6g40w1kpk717"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/audreyt/findbin")
+ (synopsis "Get the absolute path of the running program")
+ (description
+ "This module locates the full directory of the running program, to allow
+the use of paths relative to it. FindBin supports invocation of Haskell
+programs via \"ghci\", via \"runhaskell/runghc\", as well as compiled as
+an executable.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here