summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:45:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:20 +0100
commitf8295ee6dea95eec54196c967f034a1597e45e70 (patch)
tree11fad5ec6e055fb35af57bdf1d0697cfe7ee446d
parent9c30cf65d2b2f1f529f9e7dc4ea58e14b3035f9e (diff)
downloadguix-patches-f8295ee6dea95eec54196c967f034a1597e45e70.tar
guix-patches-f8295ee6dea95eec54196c967f034a1597e45e70.tar.gz
gnu: Add r-clusterprofiler.
* gnu/packages/bioconductor.scm (r-clusterprofiler): New variable.
-rw-r--r--gnu/packages/bioconductor.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 098cee8100..46d1880ccb 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2849,3 +2849,36 @@ data.")
interpreting functional enrichment results obtained from ORA or GSEA analyses.
All the visualization methods are developed based on ggplot2 graphics.")
(license license:artistic2.0)))
+
+(define-public r-clusterprofiler
+ (package
+ (name "r-clusterprofiler")
+ (version "3.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "clusterProfiler" version))
+ (sha256
+ (base32
+ "1v4fh8ll7zk8yhbaa0nq9xvqrb05kyvbpwkqpnjf07s873805rxm"))))
+ (properties
+ `((upstream-name . "clusterProfiler")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-dose" ,r-dose)
+ ("r-enrichplot" ,r-enrichplot)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-go-db" ,r-go-db)
+ ("r-gosemsim" ,r-gosemsim)
+ ("r-magrittr" ,r-magrittr)
+ ("r-plyr" ,r-plyr)
+ ("r-qvalue" ,r-qvalue)
+ ("r-rvcheck" ,r-rvcheck)
+ ("r-tidyr" ,r-tidyr)))
+ (home-page "https://guangchuangyu.github.io/software/clusterProfiler/")
+ (synopsis "Analysis and visualization of functional profiles for gene clusters")
+ (description
+ "This package implements methods to analyze and visualize functional
+profiles (GO and KEGG) of gene and gene clusters.")
+ (license license:artistic2.0)))