summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:44:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:19 +0100
commite25828839d81b097f59d9c217aa3386d232766c3 (patch)
tree096d21e5c47eac6a999e89ecee888869a3f5790d
parent1c59ec707e3a6f4496af411d4e2f46fbd4628ce4 (diff)
downloadguix-patches-e25828839d81b097f59d9c217aa3386d232766c3.tar
guix-patches-e25828839d81b097f59d9c217aa3386d232766c3.tar.gz
gnu: Add r-ggplotify.
* gnu/packages/cran.scm (r-ggplotify): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c943efe507..5ca6be6767 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13145,3 +13145,30 @@ conversion and comparisons implemented in C++, and offers 100-fold speed
improvements over the @code{convertColor} function in the @code{grDevices}
package.")
(license license:expat)))
+
+(define-public r-ggplotify
+ (package
+ (name "r-ggplotify")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggplotify" version))
+ (sha256
+ (base32
+ "14hqlpvnaq5psz1ljcpw9isa06827rg3fm5c1dx159rsjfi56yby"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gridgraphics" ,r-gridgraphics)
+ ("r-rvcheck" ,r-rvcheck)))
+ (home-page "https://github.com/GuangchuangYu/ggplotify")
+ (synopsis "Convert plots to @code{grob} or @code{ggplot} object")
+ (description
+ "This package provides tools to convert plot function calls (using
+expression or formula) to @code{grob} or @code{ggplot} objects that are
+compatible with the @code{grid} and @code{ggplot2} environment. With this
+package, we are able to e.g. use @code{cowplot} to align plots produced by
+@code{base} graphics, @code{grid}, @code{lattice}, @code{vcd} etc. by
+converting them to @code{ggplot} objects.")
+ (license license:artistic2.0)))