summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:44:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:19 +0100
commitd4ff09af0d2b9883982f5aec331fe698bf25cd0c (patch)
treef430f8eb9f2a93b5faffe3719263b1fa84a509fd
parent09dde7fb01b3685f1549661d50aeecb18696bc05 (diff)
downloadguix-patches-d4ff09af0d2b9883982f5aec331fe698bf25cd0c.tar
guix-patches-d4ff09af0d2b9883982f5aec331fe698bf25cd0c.tar.gz
gnu: Add r-urltools.
* gnu/packages/cran.scm (r-urltools): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1690320879..8d1a78b2cb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13246,3 +13246,29 @@ dilations) for polygonal regions and polygonal lines. It computes the
Minkowski Sum of general polygons. There is a function for removing
self-intersections from polygon data.")
(license license:boost1.0)))
+
+(define-public r-urltools
+ (package
+ (name "r-urltools")
+ (version "1.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "urltools" version))
+ (sha256
+ (base32
+ "18lp66f2l504b8q3j4xy8j9pyzzlljw9f112sn6qii1cg83072wm"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)
+ ("r-triebeard" ,r-triebeard)))
+ (home-page "https://github.com/Ironholds/urltools/")
+ (synopsis "Vectorized tools for URL handling and parsing")
+ (description
+ "This package provides a toolkit for all URL-handling needs, including
+encoding and decoding, parsing, parameter extraction and modification. All
+functions are designed to be both fast and entirely vectorized. It is
+intended to be useful for people dealing with web-related datasets, such as
+server-side logs, although may be useful for other situations involving large
+sets of URLs.")
+ (license license:expat)))