summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:24:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:19 +0100
commitaf26c7ae7010d72c8f4759f3f4e2421cd9a2183b (patch)
treebdd463a979193e20982ab966f58d5ffdc9e7472e
parent0d50d0df0866430814d3b55cb305c352e796cd55 (diff)
downloadguix-patches-af26c7ae7010d72c8f4759f3f4e2421cd9a2183b.tar
guix-patches-af26c7ae7010d72c8f4759f3f4e2421cd9a2183b.tar.gz
gnu: Add r-fgsea.
* gnu/packages/bioconductor.scm (r-fgsea): New variable.
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 59ca93dde8..3f5e61f6f5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2724,3 +2724,32 @@ and NE_k statistics in a statistical framework for determining whether a
specified group of genes for a pathway has a coordinated association with a
phenotype of interest.")
(license license:gpl2)))
+
+(define-public r-fgsea
+ (package
+ (name "r-fgsea")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "fgsea" version))
+ (sha256
+ (base32
+ "0cxxvlmg340l5l5fz4abbwppiri0ibg4navvq5k3wg511mz8ma2q"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocparallel" ,r-biocparallel)
+ ("r-data-table" ,r-data-table)
+ ("r-fastmatch" ,r-fastmatch)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)
+ ("r-matrix" ,r-matrix)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/ctlab/fgsea/")
+ (synopsis "Fast gene set enrichment analysis")
+ (description
+ "The package implements an algorithm for fast gene set enrichment
+analysis. Using the fast algorithm allows to make more permutations and get
+more fine grained p-values, which allows to use accurate stantard approaches
+to multiple hypothesis correction.")
+ (license license:expat)))