summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:45:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:20 +0100
commit9c30cf65d2b2f1f529f9e7dc4ea58e14b3035f9e (patch)
treec7bd87985be4ecb1078e683943b110d483cdedd1
parent305050b56d5df003f986cbca5fedb4b9b5cd45bb (diff)
downloadguix-patches-9c30cf65d2b2f1f529f9e7dc4ea58e14b3035f9e.tar
guix-patches-9c30cf65d2b2f1f529f9e7dc4ea58e14b3035f9e.tar.gz
gnu: Add r-enrichplot.
* gnu/packages/bioconductor.scm (r-enrichplot): New variable.
-rw-r--r--gnu/packages/bioconductor.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0c7be1c7d5..098cee8100 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2813,3 +2813,39 @@ including hypergeometric model and gene set enrichment analysis are also
implemented for discovering disease associations of high-throughput biological
data.")
(license license:artistic2.0)))
+
+(define-public r-enrichplot
+ (package
+ (name "r-enrichplot")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "enrichplot" version))
+ (sha256
+ (base32
+ "0cxqfpy6py4k3z3lnlkiwx89r4ymfpdc4hm25dfpazqgjflz5is7"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-cowplot" ,r-cowplot)
+ ("r-dose" ,r-dose)
+ ("r-europepmc" ,r-europepmc)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-ggplotify" ,r-ggplotify)
+ ("r-ggraph" ,r-ggraph)
+ ("r-ggridges" ,r-ggridges)
+ ("r-gosemsim" ,r-gosemsim)
+ ("r-gridextra" ,r-gridextra)
+ ("r-igraph" ,r-igraph)
+ ("r-purrr" ,r-purrr)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-reshape2" ,r-reshape2)
+ ("r-upsetr" ,r-upsetr)))
+ (home-page "https://github.com/GuangchuangYu/enrichplot")
+ (synopsis "Visualization of functional enrichment result")
+ (description
+ "The enrichplot package implements several visualization methods for
+interpreting functional enrichment results obtained from ORA or GSEA analyses.
+All the visualization methods are developed based on ggplot2 graphics.")
+ (license license:artistic2.0)))