summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:44:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:19 +0100
commit85431ca3a8c125965477de17f2b165299b98266f (patch)
tree775448762090d7e104c74165a0b9c4b65acb7ac6
parente25828839d81b097f59d9c217aa3386d232766c3 (diff)
downloadguix-patches-85431ca3a8c125965477de17f2b165299b98266f.tar
guix-patches-85431ca3a8c125965477de17f2b165299b98266f.tar.gz
gnu: Add r-triebeard.
* gnu/packages/cran.scm (r-triebeard): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5ca6be6767..102a223c6f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13172,3 +13172,25 @@ package, we are able to e.g. use @code{cowplot} to align plots produced by
@code{base} graphics, @code{grid}, @code{lattice}, @code{vcd} etc. by
converting them to @code{ggplot} objects.")
(license license:artistic2.0)))
+
+(define-public r-triebeard
+ (package
+ (name "r-triebeard")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "triebeard" version))
+ (sha256
+ (base32
+ "1hqyz57gph02c9fdc07lxz113bbklif3g18sw8jan6pakhhdc7dz"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/Ironholds/triebeard/")
+ (synopsis "Radix trees in Rcpp")
+ (description
+ "Radix trees, or tries, are key-value data structures optimized for
+efficient lookups, similar in purpose to hash tables. This package provides
+an implementation of radix trees for use in R programming and in developing
+packages with Rcpp.")
+ (license license:expat)))