summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:20:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:18 +0100
commit81df4e1e98a1a2eabc23951775f42bcdac9ceeaa (patch)
tree930b15e3b6015bbea949e1fa5c21edaa3625d66d
parent06013a45aab44a6d3febc81f333f8b12c9cab9e8 (diff)
downloadguix-patches-81df4e1e98a1a2eabc23951775f42bcdac9ceeaa.tar
guix-patches-81df4e1e98a1a2eabc23951775f42bcdac9ceeaa.tar.gz
gnu: Add r-rttf2pt1.
* gnu/packages/cran.scm (r-rttf2pt1): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 31f3d3f721..88ec491f02 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12968,3 +12968,27 @@ see: G. Thanei, N. Meinshausen and R. Shah (2016). The xyz algorithm for fast
interaction search in high-dimensional data.")
;; Any version of the GPL.
(license license:gpl2+)))
+
+(define-public r-rttf2pt1
+ (package
+ (name "r-rttf2pt1")
+ (version "1.3.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Rttf2pt1" version))
+ (sha256
+ (base32
+ "12hf9r3mhjr9sawdvf7qhjf1zph2q64f77i81jwvy7awidbm0kja"))))
+ (properties `((upstream-name . "Rttf2pt1")))
+ (build-system r-build-system)
+ (home-page "https://github.com/wch/Rttf2pt1")
+ (synopsis "Font conversion utility")
+ (description
+ "This package contains the program @code{ttf2pt1}, for use with the
+@code{extrafont} package.")
+ ;; Most of the files are covered under the Expat license. Some files are
+ ;; covered under BSD-3. Deviations for individual files are recorded in
+ ;; the LICENSE file.
+ (license (list license:bsd-3 license:expat
+ (license:non-copyleft "file://LICENSE")))))