summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 15:43:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 16:17:19 +0100
commit585d5ae0fb7f8092d1d07f765108574001d1a3b2 (patch)
tree13d54ea308e5d3d1918dea96172c254148887691
parentf8a5af4653077502a3818b4c71ad7bf1be67389a (diff)
downloadguix-patches-585d5ae0fb7f8092d1d07f765108574001d1a3b2.tar
guix-patches-585d5ae0fb7f8092d1d07f765108574001d1a3b2.tar.gz
gnu: Add r-gridgraphics.
* gnu/packages/cran.scm (r-gridgraphics): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4e6604ac83..5f1dd03983 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13097,3 +13097,26 @@ yeast.")
;; files are made available under the Creative Commons Attribution 4.0
;; International license.
(license (list license:expat license:cc-by4.0))))
+
+(define-public r-gridgraphics
+ (package
+ (name "r-gridgraphics")
+ (version "0.3-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gridGraphics" version))
+ (sha256
+ (base32
+ "1p94flvq5h3x817pl1m0aj3sim87x6zdbpv9xrgdnqw3rxfzwgqs"))))
+ (properties `((upstream-name . "gridGraphics")))
+ (build-system r-build-system)
+ (home-page "https://github.com/pmur002/gridgraphics")
+ (synopsis "Redraw base graphics using @code{grid} graphics")
+ (description
+ "This package provides functions to convert a page of plots drawn with
+the @code{graphics} package into identical output drawn with the @code{grid}
+package. The result looks like the original @code{graphics}-based plot, but
+consists of @code{grid} grobs and viewports that can then be manipulated with
+@code{grid} functions (e.g., edit grobs and revisit viewports).")
+ (license license:gpl2+)))