summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2021-11-05 11:21:12 -0700
committerVagrant Cascadian <vagrant@debian.org>2021-11-05 11:57:48 -0700
commit3827c66dc1d9760f6f7f4753a518124075f10e64 (patch)
tree70cd5af55523b9d3443128cc8df972c05e870133
parent1ffc0a6be3c1613b2d99ceea098174d1f11f6f3f (diff)
downloadguix-patches-3827c66dc1d9760f6f7f4753a518124075f10e64.tar
guix-patches-3827c66dc1d9760f6f7f4753a518124075f10e64.tar.gz
gnu: diffoscope: Update to 190.
* gnu/packages/diffoscope.scm (diffoscope): Update to 190. [arguments]: Remove 'skip-python-tests phase.
-rw-r--r--gnu/packages/diffoscope.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 5a227d059e..3f5928d23b 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -73,7 +73,7 @@
(define-public diffoscope
(package
(name "diffoscope")
- (version "189")
+ (version "190")
(source
(origin
(method git-fetch)
@@ -82,7 +82,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0dai9gwsr9xnficjy8myq6xr301y4iy82aidm936qsqjwrp8q1sm"))
+ (base32 "10q93qybwqf2nzj3iakw1pxhccq10ixm9fn7xgdr4p88qb0wchb5"))
(patches
(search-patches "diffoscope-fix-llvm-test.patch"))))
(build-system python-build-system)
@@ -109,13 +109,6 @@
(string-append "['" (which "stat") "',"))
(("\\['getfacl',")
(string-append "['" (which "getfacl") "',")))))
- (add-after 'unpack 'skip-python-tests
- (lambda _
- ;; Python tests appear to assume python 3.9, remove
- ;; phase when python is upgraded
- (substitute* "tests/comparators/test_python.py"
- (("def test_identification")
- "def skip_test_identification"))))
(add-after 'build 'build-man-page
(lambda* (#:key (make-flags '()) #:allow-other-keys)
(apply invoke "make" "-C" "doc" make-flags)))