summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Sassmannshausen <alex@pompo.co>2016-06-29 15:23:42 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-02 16:24:35 +0200
commitd2d6cd67c2bf6a914cffbd69398d4123c92b743a (patch)
treefe7f5a601d5a23748eb36da5fa7e4a93641a3e6e
parente957060ccbbff2ed579f5073d75c7bfdc718bfb1 (diff)
downloadguix-patches-d2d6cd67c2bf6a914cffbd69398d4123c92b743a.tar
guix-patches-d2d6cd67c2bf6a914cffbd69398d4123c92b743a.tar.gz
gnu: Add perl-test-class.
* gnu/packages/perl.scm (perl-test-class): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/perl.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 926631d741..6530e3f9a5 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4920,6 +4921,37 @@ framework base class. It concentrates on offering reusable data driven
patterns, so that you can write tests with a minimum of code.")
(license (package-license perl))))
+(define-public perl-test-class
+ (package
+ (name "perl-test-class")
+ (version "0.50")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://cpan.metacpan.org/authors/id/E/ET/ETHER/Test-Class-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0l0kk5jvxjkic2jkf1r7v41irb344aasnzr3f5ygjgxgiknm9489"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)))
+ (inputs
+ `(("perl-module-runtime" ,perl-module-runtime)
+ ("perl-mro-compat" ,perl-mro-compat)
+ ("perl-try-tiny" ,perl-try-tiny)))
+ (home-page "http://search.cpan.org/dist/Test-Class")
+ (synopsis "Easily create test classes in an xUnit/JUnit style")
+ (description "@code{Test::Class} provides a simple way of creating classes
+and objects to test your code in an xUnit style.
+
+Built using @code{Test::Builder}, it was designed to work with other
+@code{Test::Builder} based modules (@code{Test::More},
+@code{Test::Differences}, @code{Test::Exception}, etc.).")
+ (license (package-license perl))))
+
(define-public perl-test-cleannamespaces
(package
(name "perl-test-cleannamespaces")