summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-28 22:33:09 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-10-28 23:04:47 +0100
commit2f3c2dafefa08244e0d5834f06416d8dd5a102e4 (patch)
treea103c518c42aecbc5e2f32e7bfa85db04feffc46
parent2a74f9284e7a798c26938d8475522c8312c33dea (diff)
downloadguix-patches-2f3c2dafefa08244e0d5834f06416d8dd5a102e4.tar
guix-patches-2f3c2dafefa08244e0d5834f06416d8dd5a102e4.tar.gz
gnu: python-lxml: Run the test suite.
* gnu/packages/python-xyz.scm (python-lxml)[arguments]: New field.
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3a3c573c6f..e11a3ea42b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5972,6 +5972,11 @@ the GObject Introspection bindings to libnotify for non-GTK applications.")
(base32
"14jnpfcpgqr9sx8ppd286jzcbk0b36hbqsvd8jkvffipzw5v8768"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "make" "test"))))))
(inputs
`(("libxml2" ,libxml2)
("libxslt" ,libxslt)))