summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-10-23 15:26:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-16 15:43:51 +0200
commitb531ba43043936ea6a59bd33486ef7e6ad709473 (patch)
tree2f67ed388d92faa4455d24e2dcb5659f4f29d4ae
parent8000fc4fa022c3053574b580639f67edd8321c31 (diff)
downloadguix-patches-b531ba43043936ea6a59bd33486ef7e6ad709473.tar
guix-patches-b531ba43043936ea6a59bd33486ef7e6ad709473.tar.gz
gnu: Add ocaml4.07-alcotest.
* gnu/packages/ocaml.scm (ocaml4.07-alcotest): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 932220d188..767cacfb3e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2268,6 +2268,7 @@ immutability.")
("ocaml-stdlib-shims" ,ocaml-stdlib-shims)
("ocaml-uuidm" ,ocaml-uuidm)
("ocaml-uutf" ,ocaml-uutf)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-alcotest))))
(home-page "https://github.com/mirage/alcotest")
(synopsis "Lightweight OCaml test framework")
(description "Alcotest exposes simple interface to perform unit tests. It
@@ -2278,6 +2279,22 @@ displayed at the end of the run (with the full logs ready to inspect), with a
simple (yet expressive) query language to select the tests to run.")
(license license:isc)))
+(define-public ocaml4.07-alcotest
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-alcotest)
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/alcotest")
+ (commit version)))
+ (file-name (git-file-name "ocaml-alcotest" version))
+ (sha256
+ (base32
+ "1frwi185z4aadmaf0vp8xk5227nyg7nmh28ijj5l7ncjr5slvhz8"))))
+ (properties '()))))
+
(define-public ocaml-ppx-tools
(package
(name "ocaml-ppx-tools")