summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-09 10:12:59 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-11 15:39:08 +0000
commitf2cbee9238585e98b04ce7b667d0e676fa8893db (patch)
tree3a701bfdee889fe0f91a1276f14d3c3aff96dbfb
parent3cd3703b36a782634e9fb4c1be2c3dfa372e36c8 (diff)
downloadguix-patches-f2cbee9238585e98b04ce7b667d0e676fa8893db.tar
guix-patches-f2cbee9238585e98b04ce7b667d0e676fa8893db.tar.gz
gnu: Add rust-seahash-4.
* gnu/packages/crates-io.scm (rust-seahash-4): New variable.
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 70654f696d..459c1a58c8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -44521,6 +44521,26 @@ Pwrite traits from the scroll crate.")
proven statistical guarantees.")
(license license:expat)))
+(define-public rust-seahash-4
+ (package
+ (name "rust-seahash")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "seahash" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0sxsb64np6bvnppjz5hg4rqpnkczhsl8w8kf2a5lr1c08xppn40w"))))
+ (build-system cargo-build-system)
+ (arguments '(#:skip-build? #t))
+ (home-page "https://gitlab.redox-os.org/redox-os/seahash")
+ (synopsis "Hash function with proven statistical guarantees")
+ (description
+ "This package provides a fast, portable hash function with proven
+statistical guarantees.")
+ (license license:expat)))
+
(define-public rust-seccomp-sys-0.1
(package
(name "rust-seccomp-sys")