summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-02-02 16:51:35 -0300
committerVinicius Monego <monego@posteo.net>2022-02-03 10:14:39 -0300
commit5fe10d1b97b1ea183eebcc44de175e1d135ae558 (patch)
treec2b0d10c66d0f030793f172bdb25e6fab5c48d37
parent102a02896d4bf8eeed346521aaec8a7bda46c58b (diff)
downloadguix-patches-5fe10d1b97b1ea183eebcc44de175e1d135ae558.tar
guix-patches-5fe10d1b97b1ea183eebcc44de175e1d135ae558.tar.gz
gnu: mixxx: Update to 2.3.2.
* gnu/packages/music.scm (mixxx): Update to 2.3.2. [arguments]<#:phases>: Don't override the 'check phase as the previously failing test passes in this version. [native-inputs]: Use the new style. [inputs]: Likewise.
-rw-r--r--gnu/packages/music.scm109
1 files changed, 52 insertions, 57 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 43b1059304..211f7a6b11 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2019 Riku Viitanen <riku.viitanen0@gmail.com>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
-;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
@@ -2176,7 +2176,7 @@ users to select LV2 plugins and run them with jalv.")
(define-public mixxx
(package
(name "mixxx")
- (version "2.3.1")
+ (version "2.3.2")
(source
(origin
(method git-fetch)
@@ -2188,7 +2188,7 @@ users to select LV2 plugins and run them with jalv.")
(search-patches "mixxx-link-qtscriptbytearray-qtscript.patch"
"mixxx-system-googletest-benchmark.patch"))
(sha256
- (base32 "04781s4ajdlwgvf12v2mvh6ia5grhc5pn9d75b468qci3ilnmkg8"))
+ (base32 "1h26vpf60rk56fsw1nvmxihg7ammlj8q4zgim49q4s4ww7j8wwqj"))
(modules '((guix build utils)))
(snippet
;; Delete libraries that we already have or don't need.
@@ -2210,11 +2210,6 @@ users to select LV2 plugins and run them with jalv.")
(lambda _
(system "Xvfb &")
(setenv "DISPLAY" ":0")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; This test fails. I don't know why.
- (invoke "ctest" "-E" "TagLibTest.WriteID3v2Tag"))))
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -2223,56 +2218,56 @@ users to select LV2 plugins and run them with jalv.")
`("LD_LIBRARY_PATH" ":" prefix
,(list (string-append faad2 "/lib"))))))))))
(native-inputs
- `(("benchmark" ,benchmark)
- ("googletest" ,googletest)
- ("python" ,python-wrapper)
- ("qttools" ,qttools)
- ("xorg-server" ,xorg-server-for-tests)))
+ (list benchmark
+ googletest
+ python-wrapper
+ qttools
+ xorg-server-for-tests))
(inputs
- `(("bash" ,bash-minimal)
- ("chromaprint" ,chromaprint)
- ("faad2" ,faad2)
- ("ffmpeg" ,ffmpeg)
- ("fftw" ,fftw)
- ("flac" ,flac)
- ("glu" ,glu)
- ("hidapi" ,hidapi)
- ("jack" ,jack-1)
- ("lame" ,lame)
- ("libdjinterop" ,libdjinterop)
- ("libebur128" ,libebur128)
- ("libid3tag" ,libid3tag)
- ("libkeyfinder" ,libkeyfinder)
- ("libmad" ,libmad)
- ("libmp4v2" ,libmp4v2)
- ("libmodplug" ,libmodplug)
- ("libsndfile" ,libsndfile)
- ("libshout" ,libshout)
- ;; XXX: Mixxx complains the libshout-idjc package suffers from bug
- ;; lp1833225 and refuses to use it. Use the bundle for now.
- ;; ("libshout-idjc" ,libshout-idjc)
- ("libusb" ,libusb)
- ("libvorbis" ,libvorbis)
- ("lilv" ,lilv)
- ("mp3guessenc" ,mp3guessenc)
- ("openssl" ,openssl)
- ("opusfile" ,opusfile)
- ("portaudio" ,portaudio)
- ("portmidi" ,portmidi)
- ("protobuf" ,protobuf)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
- ("qtkeychain" ,qtkeychain)
- ("qtscript" ,qtscript)
- ("qtsvg" ,qtsvg)
- ("qtx11extras" ,qtx11extras)
- ("rubberband" ,rubberband)
- ("soundtouch" ,soundtouch)
- ("sqlite" ,sqlite)
- ("taglib" ,taglib)
- ("upower" ,upower)
- ("vamp" ,vamp)
- ("wavpack" ,wavpack)))
+ (list bash-minimal
+ chromaprint
+ faad2
+ ffmpeg
+ fftw
+ flac
+ glu
+ hidapi
+ jack-1
+ lame
+ libdjinterop
+ libebur128
+ libid3tag
+ libkeyfinder
+ libmad
+ libmp4v2
+ libmodplug
+ libsndfile
+ libshout
+ ;; XXX: Mixxx complains the libshout-idjc package suffers from bug
+ ;; lp1833225 and refuses to use it. Use the bundle for now.
+ ;; libshout-idjc
+ libusb
+ libvorbis
+ lilv
+ mp3guessenc
+ openssl
+ opusfile
+ portaudio
+ portmidi
+ protobuf
+ qtbase-5
+ qtdeclarative
+ qtkeychain
+ qtscript
+ qtsvg
+ qtx11extras
+ rubberband
+ soundtouch
+ sqlite
+ taglib
+ upower
+ vamp
+ wavpack))
(home-page "https://mixxx.org/")
(synopsis "DJ software to perform live mixes")
(description "Mixxx is a DJ software. It integrates the tools DJs need to