summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-02-01 19:36:38 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-02-03 12:00:22 +0100
commit102a02896d4bf8eeed346521aaec8a7bda46c58b (patch)
tree97e9080b8cf5cb3865acfe9c0a971229e87accfe
parentd6824f6de42f036d293844e049add0650045249a (diff)
downloadguix-patches-102a02896d4bf8eeed346521aaec8a7bda46c58b.tar
guix-patches-102a02896d4bf8eeed346521aaec8a7bda46c58b.tar.gz
gnu: js-of-ocaml: Update to 4.0.0.
* gnu/packages/ocaml (js-of-ocaml): Update to 4.0.0. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 4 insertions, 15 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6c1ac057a4..fa6cdcb0d5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020, 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 divoplade <d@divoplade.fr>
-;;; Copyright © 2020, 2021 pukkamustard <pukkamustard@posteo.net>
+;;; Copyright © 2020, 2021, 2022 pukkamustard <pukkamustard@posteo.net>
;;; Copyright © 2021 aecepoglu <aecepoglu@fastmail.fm>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
@@ -7639,7 +7639,7 @@ libraries.")
(define-public js-of-ocaml
(package
(name "js-of-ocaml")
- (version "3.11.0")
+ (version "4.0.0")
(source
(origin
(method git-fetch)
@@ -7648,20 +7648,9 @@ libraries.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1x5f1ph9wgx0mgyibssssnrcwp69ihw66gzhsnz9h79czgzyjpp2"))))
+ (base32 "0iyhl9z57j53j2jvyqcwmxhbvy23l6g80aa0abmlgwam14yskspf"))))
(build-system dune-build-system)
- (arguments
- `(#:test-target "."
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-failing-test
- (lambda _
- ;; Formating difference
- (with-output-to-file "compiler/tests-jsoo/bin/error2.expected"
- (lambda _
- (format #t
- "Fatal error: exception Match_failure(\
-\"compiler/tests-jsoo/bin/error2.ml\", 11, 2)\n\n"))))))))
+ (arguments `(#:test-target "."))
(propagated-inputs
(list ocaml-ppxlib
ocaml-uchar