summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-05-28 20:49:24 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-05-31 23:20:00 +0200
commit3b00a6b008be168cf378edef4543858439d212ae (patch)
treea7e59771d4d08c170dc06d5ececc592a329ea856
parent620daa6b342d4d72fef2d9ce1ba2fbd11a65266b (diff)
downloadguix-patches-3b00a6b008be168cf378edef4543858439d212ae.tar
guix-patches-3b00a6b008be168cf378edef4543858439d212ae.tar.gz
gnu: Add emacs-dracula-theme.
* gnu/packages/emacs-xyz.scm (emacs-dracula-theme): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 08730fc574..4a2452577c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9080,6 +9080,27 @@ known loosely as deftheme. Many mode-specific customizations are included.")
by zenburn, sinburn and similar themes, but slowly diverging from them.")
(license license:gpl3+))))
+(define-public emacs-dracula-theme
+ (package
+ (name "emacs-dracula-theme")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dracula/emacs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15y2djc5jljlvls1x9kp50m1kp0dcksmyixafsyimj66xpq9ngh0"))))
+ (build-system emacs-build-system)
+ (home-page "https://draculatheme.com/")
+ (synopsis "Dark theme for Emacs")
+ (description
+ "Dracula is a dark color theme for many editors, shells and more. This
+package provides the Emacs theme.")
+ (license license:expat)))
+
(define-public emacs-auto-complete
(package
(name "emacs-auto-complete")