summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-03 18:09:25 +0100
committerMarius Bakke <marius@gnu.org>2022-02-03 23:39:46 +0100
commit3e6dcd1ee5ad47214b052ad7fda28908cf8ff514 (patch)
treec3860580769dbd3fcab88423f977738cccc742d8
parent7d90a6c847b4cdf51c462c53e57bafd6834afc60 (diff)
downloadguix-patches-3e6dcd1ee5ad47214b052ad7fda28908cf8ff514.tar
guix-patches-3e6dcd1ee5ad47214b052ad7fda28908cf8ff514.tar.gz
gnu: python-can: Update to 3.3.4.
* gnu/packages/python-xyz.scm (python-can): Update to 3.3.4. [arguments]: Adjust version constraints.
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b0374622f2..999003176d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2014,14 +2014,14 @@ class.")
(define-public python-can
(package
(name "python-can")
- (version "3.3.3")
+ (version "3.3.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-can" version))
(sha256
(base32
- "123lz1bl6xf3d0fvxzr4bg4884yg4m9s21z6xd2m68zhnbv9rmpc"))))
+ "0jclrvyxasaaxr0albq0kqrnrfqdgqxs7m2qw9nd8kfwg8xj4g1d"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -2030,7 +2030,8 @@ class.")
(substitute* "setup.py"
(("mock~=2\\.0") "mock")
(("coverage<5") "coverage")
- (("pytest~=4\\.3") "pytest")
+ (("pytest~=4\\.6") "pytest")
+ (("pytest-timeout~=1\\.3") "pytest-timeout")
(("hypothesis~=4\\.56") "hypothesis"))
#t))
(add-after 'unpack 'fix-broken-tests