summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-16 22:58:12 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-23 19:01:01 +0200
commit12308d19b4b6008e8d8d9c70efa6b72a64ab3cf7 (patch)
tree56a7ba9c8147768f8d77d5972d768dfc963606e7
parent0b298cb9f7212e68dd89da5c78d26ac8622ad611 (diff)
downloadguix-patches-12308d19b4b6008e8d8d9c70efa6b72a64ab3cf7.tar
guix-patches-12308d19b4b6008e8d8d9c70efa6b72a64ab3cf7.tar.gz
gnu: Add python-charset-normalizer.
* gnu/packages/python-xyz.scm (python-charset-normalizer): New variable.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 88c89ed201..7239fa1584 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11819,6 +11819,27 @@ automatically detect a wide range of file encodings.")
(define-public python2-chardet
(package-with-python2 python-chardet))
+(define-public python-charset-normalizer
+ (package
+ (name "python-charset-normalizer")
+ (version "2.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "charset-normalizer" version))
+ (sha256
+ (base32 "0rr3iv2xw4rz5ijnfqk229fw85cq6p6rhqqsilm0ldzncblfg63h"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/ousret/charset_normalizer")
+ (synopsis "Universal Charset Detector, alternative to Chardet")
+ (description "This library helps you read text from an unknown charset
+encoding. Motivated by @code{chardet}, it tries to resolve the issue by
+taking a new approach. All IANA character set names for which the Python core
+library provides codecs are supported.")
+ (license license:expat)))
+
(define-public python-docopt
(package
(name "python-docopt")