summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-01 10:54:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-01 10:54:22 +0200
commitfabfe0b99c4500e3e381933ab769e462c95555e1 (patch)
tree857d2ad05dd405e5ea30b60cf7d8c293d76c221e
parent48fd0de9629b707815fd490aa5a0c3410721ae3a (diff)
downloadguix-patches-fabfe0b99c4500e3e381933ab769e462c95555e1.tar
guix-patches-fabfe0b99c4500e3e381933ab769e462c95555e1.tar.gz
gnu: emacspeak: Update to 52.0.
* gnu/packages/emacs-xyz.scm (emacspeak): Update to 52.0. [arguments]: Add phase to remove a non-existing file. Change executable. [inputs]: Use espeak-ng instead of espeak. [description]: Typographic fix.
-rw-r--r--gnu/packages/emacs-xyz.scm31
1 files changed, 17 insertions, 14 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7c014cfd4c..c1f7f1fe06 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9853,7 +9853,7 @@ highlights quasi-quoted expressions.")
(define-public emacspeak
(package
(name "emacspeak")
- (version "50.0")
+ (version "52.0")
(source
(origin
(method url-fetch)
@@ -9861,14 +9861,17 @@ highlights quasi-quoted expressions.")
"https://github.com/tvraman/emacspeak/releases/download/"
version "/emacspeak-" version ".tar.bz2"))
(sha256
- (base32
- "0rsj7rzfyqmyidfsjrhjnxi2d43axx6r3gac1fhv5xkkbiiqzqkb"))))
+ (base32 "0x5b0s38r5ih2lk7f5hasi9arrgxlmmq5jaddadbxi8in2gw2jzl"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list (string-append "prefix="
(assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'delete-broken-symlink
+ (lambda _
+ (delete-file "lisp/sudoku.el")
+ #t))
(replace 'configure
(lambda _
(setenv "SHELL" (which "sh"))
@@ -9893,12 +9896,12 @@ highlights quasi-quoted expressions.")
'("etc" "info" "js" "lisp" "media" "servers" "sounds"
"stumpwm" "xsl"))
;; Make sure emacspeak is loaded from the correct directory.
- (substitute* "etc/emacspeak.sh"
- (("/lisp/emacspeak-setup.el")
+ (substitute* "run"
+ (("\\./lisp/emacspeak-setup.el")
(string-append lisp "/lisp/emacspeak-setup.el")))
;; Install the convenient startup script.
(mkdir-p bin)
- (copy-file "etc/emacspeak.sh" (string-append bin "/emacspeak")))
+ (copy-file "run" (string-append bin "/emacspeak")))
#t))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -9911,10 +9914,10 @@ highlights quasi-quoted expressions.")
(wrap-program emacspeak
`("DTK_PROGRAM" ":" prefix (,espeak)))
#t))))
- #:tests? #f)) ; no check target
+ #:tests? #f)) ; no check target
(inputs
`(("emacs" ,emacs)
- ("espeak" ,espeak)
+ ("espeak" ,espeak-ng)
("perl" ,perl)
("tcl" ,tcl)
("tclx" ,tclx)))
@@ -9922,12 +9925,12 @@ highlights quasi-quoted expressions.")
(synopsis "Audio desktop interface for Emacs")
(description
"Emacspeak is a speech interface that allows visually impaired users to
-interact independently and efficiently with the computer. Audio formatting
---a technique pioneered by AsTeR-- and full support for W3C's Aural CSS (ACSS)
-allows Emacspeak to produce rich aural presentations of electronic information.
-By seamlessly blending all aspects of the Internet such as Web-surfing and
-messaging, Emacspeak speech-enables local and remote information via a
-consistent and well-integrated user interface.")
+interact independently and efficiently with the computer. Audio
+formatting---a technique pioneered by AsTeR---and full support for W3C's Aural
+CSS (ACSS) allows Emacspeak to produce rich aural presentations of electronic
+information. By seamlessly blending all aspects of the Internet such as
+Web-surfing and messaging, Emacspeak speech-enables local and remote
+information via a consistent and well-integrated user interface.")
(license license:gpl2+)))
(define-public emacs-adaptive-wrap