summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-11 14:44:37 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-11 15:39:19 +0000
commitc4e5fabb6ef1a07967960f9b585847503cca0613 (patch)
treea3b9f114ecb96cc23e37053ab63e6d4409f69ae2
parent6be47c5bc56b4a2d3183a58d1c9fb2e0846c7f0f (diff)
downloadguix-patches-c4e5fabb6ef1a07967960f9b585847503cca0613.tar
guix-patches-c4e5fabb6ef1a07967960f9b585847503cca0613.tar.gz
gnu: ciri-long: Fix reference to ccs.
* gnu/packages/bioinformatics.scm (ciri-long)[arguments]: Add build phase "fix-reference-to-ccs". [inputs]: Add circtools.
-rw-r--r--gnu/packages/bioinformatics.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 13bd7b5997..3455029ed1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1475,9 +1475,20 @@ consensus sequences.")
(add-before 'build 'build-libssw
(lambda _
(with-directory-excursion "libs/striped_smith_waterman"
- (invoke "make" "libssw.so")))))))
- (inputs
- `(("python-biopython" ,python-biopython)
+ (invoke "make" "libssw.so"))))
+ (add-before 'build 'fix-reference-to-ccs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "CIRI_long/pipeline.py"
+ (("'ccs -i")
+ (string-append "'"
+ (assoc-ref inputs "circtools") "/bin/ccs"
+ " -i")))
+ ;; yuck!
+ (substitute* "CIRI_long/main.py"
+ (("os.chmod\\(lib_path.*") "")))))))
+ (inputs
+ `(("circtools" ,circtools)
+ ("python-biopython" ,python-biopython)
("python-bwapy" ,python-bwapy)
("python-cython" ,python-cython)
("python-levenshtein" ,python-levenshtein)