summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-11 13:49:12 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-11 15:39:19 +0000
commit4052310e91456530f0b5362f5895255e36d53055 (patch)
tree860dc5294d22cb37e900d985c6b985cf340720ac
parentb905d7c1d6b5ab6dc8363b142ae46069838bc200 (diff)
downloadguix-patches-4052310e91456530f0b5362f5895255e36d53055.tar
guix-patches-4052310e91456530f0b5362f5895255e36d53055.tar.gz
gnu: Add biosoup.
* gnu/packages/bioinformatics.scm (biosoup): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a731b9af06..8139ce43de 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1323,6 +1323,37 @@ relying on a complex dependency tree.")
(define-public python2-fastalite
(package-with-python2 python-fastalite))
+(define-public biosoup
+ (package
+ (name "biosoup")
+ (version "0.10.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rvaser/biosoup")
+ ;; Corresponds to version 0.10.0
+ (commit "38181f09854ff42cbd9632200a2ec9fb37a4b7b6")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02hvyka703zagx0nvv2yx3dkc748zc8g6qbrpya7r8kfkcl7y8hw"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./bin/biosoup_test")))))))
+ (native-inputs
+ `(("googletest" ,googletest)))
+ (home-page "https://github.com/rvaser/biosoup")
+ (synopsis "C++ support library for bioinformatics tools")
+ (description "Biosoup is a C++ collection of header-only data structures
+used for storage and logging in bioinformatics tools.")
+ (license license:expat)))
+
(define-public ciri-long
(package
(name "ciri-long")