summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-16 20:53:11 +0100
committerMarius Bakke <marius@gnu.org>2021-12-16 22:21:13 +0100
commit3dcf972944b1ee3d09ca03493fbbb30a87d58282 (patch)
treeae16a1ce54c23154ed0dad7b8df05d51ec1d8d5a
parent83651eef15bbdecd35b90c49de6d8476d70655a5 (diff)
downloadguix-patches-3dcf972944b1ee3d09ca03493fbbb30a87d58282.tar
guix-patches-3dcf972944b1ee3d09ca03493fbbb30a87d58282.tar.gz
gnu: python-magic: Run more tests.
* gnu/packages/python-xyz.scm (python-magic): Invoke one more test file.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8d34ea2e1e..be40a02e2a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14637,7 +14637,9 @@ syntax highlighting, markdown and more to the terminal.")
;; The test suite mandates this variable.
(setenv "LC_ALL" "en_US.UTF-8")
(if tests?
- (invoke "python" "./test/test.py")
+ (with-directory-excursion "test"
+ (invoke "python" "./test.py")
+ (invoke "python" "./libmagic_test.py"))
(format #t "test suite not run~%")))))))
(native-inputs
(list which))