summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-21 22:50:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-12-04 08:39:49 +0200
commit22fda787f679c5ff02b6d027db663b7964786fff (patch)
tree26ed860cbe2a6a8137d3150bcaa66f0f0bd609ea
parentcf3504c69c8d58ad5db6ed17083e7bee1e9acd0b (diff)
downloadguix-patches-22fda787f679c5ff02b6d027db663b7964786fff.tar
guix-patches-22fda787f679c5ff02b6d027db663b7964786fff.tar.gz
gnu: Add lekha.
* gnu/packages/enlightenment.scm (lekha): New variable.
-rw-r--r--gnu/packages/enlightenment.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index ae0f553a36..6f081cf19b 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -31,6 +31,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages game-development)
#:use-module (gnu packages gettext)
@@ -298,3 +299,33 @@ that tries to lower the barrier to getting involved in Enlightenment development
and in creating applications based on the Enlightenment Foundation Library suite.")
(license (list license:public-domain ; data/extra/skeleton
license:gpl2)))) ; edi
+
+(define-public lekha
+ (package
+ (name "lekha")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Lekha" version))
+ (sha256
+ (base32
+ "0zr6i74ik58pbzrd7r9l7sawqbdv0r2c1a9927qkqzwga27x8j15"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no test target
+ #:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-data-location
+ (lambda _ (substitute* "setup.py"
+ (("'/usr/")"'"))
+ #t)))))
+ (propagated-inputs
+ `(("python2-efl" ,python2-efl)
+ ("python2-pypdf2" ,python2-pypdf2)
+ ("python2-pyxdg" ,python2-pyxdg)))
+ (synopsis "Simple PDF viewer")
+ (description
+ "Simple PDF viewer based on the Enlightenment Foundation Libraries.")
+ (home-page "https://github.com/kaihu/lekha")
+ (license license:gpl3+)))