summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-02-02 15:36:06 +0100
committerLudovic Courtès <ludo@gnu.org>2022-02-02 17:58:20 +0100
commitd040b627b1b2f604746963a91449821c6a58c7d6 (patch)
tree1f1c7f45c94baf74c0e98e2c2dce3a857c7d25a6
parent4943ac86e4f95a2e14fd209f3fdaac74a0d9ca2e (diff)
downloadguix-patches-d040b627b1b2f604746963a91449821c6a58c7d6.tar
guix-patches-d040b627b1b2f604746963a91449821c6a58c7d6.tar.gz
gnu: perf: Help 'perf report --symfs' find separate debug info files.
* gnu/packages/linux.scm (perf)[arguments]: In 'configure' phase, modify "util/dso.c".
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e496b5e2b2..cd64fdc076 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2021, 2021-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Mark H Weaver <mhw@netris.org>
@@ -4555,7 +4555,15 @@ in a digital read-out.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "SHELL_PATH" (which "bash"))
(chdir "tools/perf")
- #t)))
+
+ ;; This file hard-codes file system layouts for specific distros
+ ;; but not for ours; address that. With this change, one can run
+ ;; "perf report --symfs=$HOME/.guix-profile" (without
+ ;; "/lib/debug") and 'perf' should be able to find separate debug
+ ;; info files.
+ (substitute* "util/dso.c"
+ (("/usr/lib/debug")
+ "/lib/debug")))))
#:make-flags (list (string-append "prefix="
(assoc-ref %outputs "out"))
"CC=gcc"