summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-19 15:28:56 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-19 15:32:04 +0100
commit80a61b38b84f881ff2bf735754c07ab8e38c763b (patch)
treea31b23c2cc1e37d6516f97349ac2e89a4abd453b
parent45e7599ce87c184e934a23df73e7738c1ce17666 (diff)
downloadguix-patches-80a61b38b84f881ff2bf735754c07ab8e38c763b.tar
guix-patches-80a61b38b84f881ff2bf735754c07ab8e38c763b.tar.gz
gnu: wireless-tools: Fix cross-compilation.
* gnu/packages/linux.scm (wireless-tools)[arguments]: Replace 'configure phase to substitute CC, AR and RANLIB Makefile variables to suitable values when cross-compiling.
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 998fd20ad8..3cec941db2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2870,8 +2870,20 @@ mapper. Kernel components are part of Linux-libre.")
(string-append "INSTALL_MAN=" %output "/share/man")
(string-append "LDFLAGS=-Wl,-rpath=" %output "/lib")
"BUILD_STATIC=")
- #:phases (modify-phases %standard-phases
- (delete 'configure))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key target #:allow-other-keys)
+ (when ,(%current-target-system)
+ ;; Cross-compilation: use the cross tools.
+ (substitute* (find-files "." "Makefile")
+ (("CC = .*$")
+ (string-append "CC = " target "-gcc\n"))
+ (("AR = .*$")
+ (string-append "AR = " target "-ar\n"))
+ (("RANLIB = .*$")
+ (string-append "RANLIB = " target "-ranlib\n"))))
+ #t)))
#:tests? #f))
(synopsis "Tools for manipulating Linux Wireless Extensions")
(description "Wireless Tools are used to manipulate the now-deprecated