summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-02-02 17:54:44 +0100
committerLudovic Courtès <ludo@gnu.org>2022-02-02 17:58:21 +0100
commitbbc26afd6198a55109589ed6477f13f1bcea1898 (patch)
treeefac79c35d62019fadafc0b8df355eac52cb7cd3
parent00762a4c4c8ecdd71cccf6afdd87ae68bf9b4964 (diff)
downloadguix-patches-bbc26afd6198a55109589ed6477f13f1bcea1898.tar
guix-patches-bbc26afd6198a55109589ed6477f13f1bcea1898.tar.gz
gnu: luminance-hdr: Fix compilation.
Reported by Leo Famulari <leo@famulari.name>. * gnu/packages/image-viewers.scm (luminance-hdr)[arguments]: In 'add-ilmbase-include-path' phase, set C_INCLUDE_PATH and be more specific about the include directory searched for.
-rw-r--r--gnu/packages/image-viewers.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 87dffbb93d..aac27b6703 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2017-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
@@ -631,11 +631,12 @@ It supports JPEG, PNG and GIF formats.")
(lambda* (#:key inputs #:allow-other-keys)
;; 'OpenEXR.pc' has a -I for IlmBase but 'FindOpenEXR.cmake' does
;; not use 'OpenEXR.pc'. Thus, we need to add
- ;; "$ilmbase/include/OpenEXR/" to the CPATH.
- (setenv "CPATH"
+ ;; "$ilmbase/include/OpenEXR/" to the CPLUS_INCLUDE_PATH.
+ (setenv "CPLUS_INCLUDE_PATH"
(string-append
- (search-input-directory inputs "include/OpenEXR")
- ":" (or (getenv "CPATH") ""))))))))
+ (dirname
+ (search-input-file inputs "include/OpenEXR/ImathInt64.h"))
+ ":" (or (getenv "CPLUS_INCLUDE_PATH") ""))))))))
(home-page "http://qtpfsgui.sourceforge.net")
(synopsis "High dynamic range (HDR) imaging application")
(description